Grid: Unscheduled Downtime
Incident Report for Track24
Resolved
Our Engineers have confirmed that the issues affecting Grid have been resolved.
Posted Aug 31, 2023 - 06:12 BST
Investigating
Our Engineering team is currently investigating this issue. We apologise for the inconvenience caused and we will update you as soon as we have identified and resolved the problem.
Posted Aug 31, 2023 - 05:39 BST
This incident affected: Grid Live Map.