Grid: Iridium satellite device report processing issue
Incident Report for Track24
Resolved
Our engineers have confirmed that this incident has been resolved. All Iridium unit position reports are being processed as normal and the report queue has cleared.
Posted May 23, 2019 - 08:14 BST
Monitoring
We are currently investigating an issue that has affected all Iridium satellite devices (Whisper, Echo, Packmaster Lo Pros, Jackal Dual, Iridium Extremes) over the past 7 hours. Position reports from these units were not reaching the platform during this time. Though the reports are now reaching the platform, there is a backlog, and it may take a while to process all of the reports.

We are currently investigating the cause of this outage and we will update you when we can confirm it is fully resolved.
Posted May 22, 2019 - 18:38 BST
This incident affected: Grid Live Map.