Google Maps service interruption on the Grid platform
Incident Report for Track24
Resolved
Our Engineers have confirmed that the issues affecting Google Maps have been resolved.
Posted Feb 14, 2019 - 07:09 GMT
Investigating
Our Engineering team is currently investigating this issue. We apologise for the inconvenience caused and we will update you as soon as we have resolved the problem.

In the meantime, please change the Map layer to Mapbox to monitor your devices on the mapping screen.
Posted Feb 14, 2019 - 06:24 GMT
This incident affected: Grid Live Map.