Interruption in Grid services
Incident Report for Track24
Resolved
The Grid monitoring platform is fully operational.

Restoring the 'Reports' feature is also currently in progress. In the meantime, if you require specific reports, please contact the support team at support@track24.com
Posted Sep 27, 2023 - 11:35 BST
Investigating
I am writing to update you on the status of our Grid Services that is impacting certain regions. Unfortunately, we are still working to resolve the interruption and currently do not have an estimated time for restoration. We apologise for the inconvenience this is causing.

We appreciate your patience and understanding as we work to resolve this issue. We will continue to provide updates on our progress as they become available.

If you have any question or would like to report a disruption please reach out to us via support@track24.com
Posted Sep 23, 2023 - 09:50 BST
This incident affected: Grid Live Map.